AnsweredAssumed Answered

Inbound Email Setup with Exchange Shared Mailbox

Question asked by Mike Sikorski on Apr 17, 2020

NOTE: This is for an On-Premise install of SugarCRM and Exchange

I am trying to setup an Inbound Mailbox for support where it will create a case for each email that is received.  I am having difficulty getting Sugar to log into the Shared Mailbox on an Exchange 2016 server.  Shared Mailboxes in Exchange 2016 are special and are created with an AD account that is disabled so logging into the account using IMAP needs a different setup.

 

IMAP on the Exchange server is configured to use SSL on port 993.  I have created an AD account which has permissions to log onto the support shared mailbox.  I am able to confirm that this account works by using the openssl command from my sugar server:

openssl s_client -crlf -connect nameOfmailserver.com:993
. LOGIN myDOmain\sa_sugar_inbound\support password
. LIST "" *
. LOGOUT

In the SugarCRM Admin section where you setup the Inbound Mailbox I set the protocol to IMAP, port 993, check mark to use SSL, and in the username field I type in: myDomain\sa_sugar_inbound\support

Clicking the "Test Settings" button times out and gives a general error message.

Clicking the Save button gives: "No optimums were saved with your Inbound Email account. Please review the settings"

IMAP Log shows the following:

myDomain/sa_sugar_inbound/support,1,38,38,authenticate,PLAIN,"R=""00000001 NO AUTHENTICATE failed."";Msg=""AuthFailed:LogonDenied,User: myDomain/sa_sugar_inbound/support"";ErrMsg=AuthFailed:LogonDenied",

I believe this is an issue on the Sugar side since testing with the openssl command yields success.

Has anyone successfully setup Sugar to login to a share exchange mailbox?  how did you do it? what am I doing wrong?

 

Current installed Sugar version: 9.0

Outcomes