Cesar Obed Gonzalez N.

Troubleshooting SDK installation

Discussion created by Cesar Obed Gonzalez N. on Apr 4, 2019

Hello

I have install the SDK recently and I had problems to setup my local environment so I want to share with you how I fixed it, I hope this help to someone.

 

1.- When I tried to execute the command './sdk init-native' I got the error 'module librsvg not found'.
   To solve this problem I had to install the module:

   A).- Go to the SDK's folder (e.g. /usr/local/developer/mobile-sdk/<SDK-version>/)

   B).- Install the module using npm: 'npm install librsvg', ( If you have many node versions you must make sure to use same node version used in the SDK installation.

   C).- Try again with the command './sdk init-native'

 

2.- When I tried to generate the APK file I got the error 'Error Forking: '/usr/local/developer/mobile-sdk/<SDK-version>/node_modules/.bin/cordova' 'clean' 'android' cwd: '/<path-custom-app>/native/platforms/android' pid: 38580 Error: spawn EACCES'

   To solve this problem I had to change the gradle permissions, e.g. sudo chmod 755 <path-android-studio>/Contents/gradle/<gradle-version>/bin/gradle

 

Note.- I had to install java1.8 because not works with the latest java version. Remember to set the environment variables.

Outcomes