AnsweredAssumed Answered

composer install errors

Question asked by Kenneth Brill on Oct 5, 2018

In SugarCRM 8.0.1 I am trying to add

 

{
    "require": {
        "lesstif/php-jira-rest-client": "^1.19"
    }
}

to my composer.json.  First I figured I would try to run the install with what was already in there and I got

 

Kenneths-MacBook-Pro:crm-workingCopy kbrill$ php composer.phar update --no-dev
Loading composer repositories with package information
The "https://satis.sugardev.team/packages.json" file could not be downloaded: failed to open stream: Operation timed out
Retrying with degraded mode, check https://getcomposer.org/doc/articles/troubleshooting.md#degraded-mode for more info

                                                                                                                           
  [Composer\Downloader\TransportException]                                                                                 
  The "https://satis.sugardev.team/packages.json" file could not be downloaded: failed to open stream: Operation timed out 
                                                                                                                           

so I removed

 

        {
            "type": "composer",
            "url": "https://satis.sugardev.team"
        }

from the composer.json and ran again, now I get

 

Kenneths-MacBook-Pro:crm-workingCopy kbrill$ php composer.phar install
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - fgrosse/phpasn1 1.5.3 requires ext-gmp * -> the requested PHP extension gmp is missing from your system.
    - fgrosse/phpasn1 1.5.3 requires ext-gmp * -> the requested PHP extension gmp is missing from your system.
    - Installation request for fgrosse/phpasn1 1.5.3 -> satisfiable by fgrosse/phpasn1[1.5.3].

How do I fix this?

Outcomes