AnsweredAssumed Answered

disable_unknown_platforms configuration setting is not working

Question asked by Shyam Gaikwad on Sep 22, 2017

Hello Team,

 

I am using SugarCRM Version 7.9.0.1 ENT, which is recently upgrade from 7.7 

 

Instance is working fine except REST API V10, after upgrade our rest api is not working. Problem in platform setting, if I use default platform "base" then it's working. please see below sample code where I am using "platform" => "exchange" , which is not working, getting Connection Failure. error. 

$oauth2_token_arguments = array(
"grant_type" => "password",
//client id - default is sugar.
//It is recommended to create your own in Admin > OAuth Keys
"client_id" => "sugar",
"client_secret" => "",
"username" => $username,
"password" => $password,
//platform type - default is base.
//It is recommend to change the platform to a custom name such as "custom_api" to avoid authentication conflicts.
"platform" => "exchange"
);

 

I gone through the below documentations but no luck, tried to add my custom platform "exchange" as per below doc, but still I am unable to login via rest api. 

http://support.sugarcrm.com/Documentation/Sugar_Developer/Sugar_Developer_Guide_7.9/Architecture/Extensions/Platforms/ 

$sugar_config['disable_unknown_platforms'] = false;

How platform parameter works in Sugar v10 REST API « Sugar Developer Blog – SugarCRM 

 

 

Please suggest me.

 

 

Thank you,

Shyam

Outcomes