AnsweredAssumed Answered

The option {silent:true} doesn't seem to turn off the "change" event in Sugarcrm 7.8

Question asked by Al Bhanji on Aug 16, 2017
Latest reply on Aug 18, 2017 by Matt Marum

Hi Guys,

 

So i wanted to change the display value of a field. I've placed the code after the sync event ( this.model.on('sync', <function>, this); ). On the <function>, i've added the code: this.model.set(<key>,<value>,{silent:true}). The silent value was set so that the pop (unsaved changes) doesn't appear. This was working previously before the upgrade to 7.8 but now it doesn't.

 

Aside from the change event that is still running, the value also isn't being set. If i remove the option for silent, then the value of the model would be set properly (but the change event is still running)

Outcomes