AnsweredAssumed Answered

Error: spawn EACCES on buildinga app on linux

Question asked by André Lopes on Jun 16, 2017
Latest reply on Jun 23, 2017 by gkhanlarov

Hi there

 

We are facing a weird issue on trying to build an app on Linux from sdk 5.1.0 beta4.

Previosly we succeded building several apps from sdk 5.0.0 beta3.

As soon as I downloaded the new sdk I decided to double check all instructions on readme.txt at sdk 5.1.0 beta4 in order to make sure everything is up to date.

 

Then the error raised!

I can install the sdk without issues (attachment install.txt). I can generate-app without issues. I can ran "./sdk init-native -p android" without issues. But I can not rn "./sdk build -p android" as I get the attached error (error.txt).

By googling I noticed that several android developers faced this same error and the provided answer was permission issue.

I can make sure it is not our case once I also tried to build the app as root but I got exactly the same error.

By debugging the sdk code I could identify it is a error related to cordova, but I can not identify precisely why.

 

Our development environment is Ubuntu 16.10 + Android Studio 2.3.3 + gradle 3.5.

 

Any insight is very appreciate.

Outcomes