AnsweredAssumed Answered

Missing gradle template?

Question asked by John Hoffmann Employee on May 12, 2017
Latest reply on May 12, 2017 by gkhanlarov

I ran into a snag trying to get setup yesterday and I'm unsure what I'm missing.

 

$ ./check-reqs-android
check-reqs-android started from "/Users/jhoffmann/sugar/mobile/5.0.0.400-1.0.1-1 beta3/sdk/check-reqs-android"

Found '/Users/jhoffmann/sugar/mobile/5.0.0.400-1.0.1-1 beta3/.nvmrc' with version <6.9.2>
v6.9.2 is already installed.
Now using node v6.9.2 (npm v3.10.9)
Android SDK not found. Make sure that it is installed. If it is not at the default location, set the ANDROID_HOME environment variable.
Could not find gradle wrapper within Android SDK. Might need to update your Android SDK.
Looked here: /Users/jhoffmann/Library/Android/sdk/tools/templates/gradle/wrapper

check-reqs-android failed

 

I did some searches and that error seems to be coming from Cordova, which seems to have a rather strict version match requirement.  Any thoughts?

Outcomes