AnsweredAssumed Answered

SugarCRM Enterprise(On Site AWS) - unable to load application

Question asked by Todd Burgess on Oct 13, 2016
Latest reply on Oct 31, 2016 by Ramana Raju Santhana

Hi,

 

As an owner of enterprise edition, I would like to migrate from On-Demand to On-Site. I edited .htaccess and config.php according to the documentation on sugar's website. I also created a case in support and confirmed that my changes in these files (along with file permissions for sugar directory) are good to go.

 

However when I tried the URL : http://<host>/<appname>, I get in the browser response:

jquery.min.js:4 GET http://ec2-107-21-89-223.compute-1.amazonaws.com/sugar7712ent/rest/v10/metadata/public?type_filter=&module_filter=&platform=base&module_dependencies=1 404 (Not Found).

 

I've tried installing community edition which works just fine.

 

I am trying to run the instance on amazonaws with LAMP stack.

- php -v       ->         PHP 5.6.26

- mysql is installed on RDS in different server.

- elasticsearch

curl -XGET 'localhost:9200'
{
"status" : 200,
"name" : "node1",
"cluster_name" : "elasticsearch",
"version" : {
"number" : "1.4.4",
"build_hash" : "c88f77ffc81301dfa9dfd81ca2232f09588bd512",
"build_timestamp" : "2015-02-19T13:05:36Z",
"build_snapshot" : false,
"lucene_version" : "4.10.3"
},
"tagline" : "You Know, for Search"
}

 

I dont know what else I should try. If someone can guide me on the process, it would be awesome.

Outcomes