Ivica Nedeljkovic

Can not create new field via Module Builder

Discussion created by Ivica Nedeljkovic on Oct 5, 2016
Latest reply on Oct 18, 2017 by Diego Goretti

I run into one very weird issue, so I want to start new discussion about it.

I am using ModuleBuilder to create new package and modules, and it worked fine until I need to create new field, where funny part start.

At first I was able to create field, but then I decided to  change field type to dropdown, so I deleted and wanted to create new one with different name, but I could not. And there were no errors or logs(I checked sugarcrm logs, php and apache logs). 

Then I tried it on one of our demo instances hosted on SugarCRM, and same issue happen there. I found similar thread (https://community.sugarcrm.com/thread/28206) where it was related to permissions, but I changed locally permissions to 777 on custom/working and custom/modulebuilder/modules... but still same.

Then I just tried to create some text fields with random names, and I found that about every 5th time field is created(I added just field name, everything else was default).

This same happen to one of my colleagues(using completely different OS) few weeks ago, and he solved issue but creating fields in Studio instead Module Builder and exporting them.

 

I decided to start debugging it using xdebug and phpstorm, and guess what? This issue disappear, and doesn't happen again locally, even after I stop debugging.

 

I will try to debug it next time I run into locally.

 

So, I just want to open this discussion just in case someone else run into same issue. It looks to me like some weird race condition. Also please reply if you had same issue.

 

Version of SugarCRM is 7.7.0.0 ENT. I will test it with 7.7.1.2 when I get time.

Outcomes