AnsweredAssumed Answered

Can't connect to MSSQL database on install

Question asked by Craig Wilson on May 16, 2016
Latest reply on Aug 18, 2016 by hqiu

I'm trying to set up a new instance. The app is hosted on a Linux box, but management wants me to use Microsoft SQL Server for the database. I got the drivers installed, but the Sugar installer can't connect. It stays at the "Verifying DB Credentials" window for what seems like a long time (maybe 2 minutes or so?) and returns

  • The provided database host, username, and/or password is invalid, and a connection to the database could not be established. Please enter a valid host, username and password


I even tried moving the Sugar application to the same server as the database with no change. The only difference is, when the Linux server is hosting the app, it also returns

  • Unable to connect to Full Text Search server, please verify your settings.

because the Elasticsearch service is running on the same Windows box as the DB. This error doesn't occur when I try hosting Sugar on the Windows box.


The SQL Server port 1433 is open on the Windows box. The credentials are correct. The instance name is correct. I even tried creating the empty database first, which I didn't think you had to do anymore, but that didn't work either.


I'm running out of ideas. If all else fails, I can probably just use MySQL/MariaDB, but I'd prefer stick with management's plan of a Windows DB server. Any suggestions?