Jerry Way

After intalling 7.7 'Unable to load the application' error (missing rest directory)

Discussion created by Jerry Way on Apr 20, 2016
Latest reply on Apr 28, 2016 by Sehrish Abdul Malik

Hi,

 

UPDATE: after opening Chrome Developer mode I found this error : The requested URL /sugarcrm/rest/v10/metadata/public was not found on this server.

And it's true the REST folder isn't there.  Neither is it in the Zip so I know it isn't a transfer error.

 

Pleased to see that 7.7 supports PHP 5.5 so I proceeded to install on a fresh Ubuntu Server 14.04.  Nice to be on a modern server version.  Install seemed to go perfectly. No errors but after install finished I get a Red box on the screen with "Unable to load the application" in it.  I'm getting no errors in the Sugar or Apache error logs.  Apache access.log seems fine with normal GET statements and no errors.

 

The one problem I had was getting passed the .htaccess can't rewrite error at the check.  I got around this at a forum suggestion of commenting out the check code.  I have all the proper settings of AllowOverride All and have enabled the rewrite module in Apache and PHP..  (I had this same problem on a 7.6 install working with PHP 5.4 but, though sugar mostly operated OK the process of installing PHP 5.4 was such a mess I'm hoping to get 7.7 going on a current OS instead of Ubuntu 12.04)

 

I've got ElasticSearch installed using OpenJDK.  I've installed jsmin using PECL..  All other requirements are met.

 

Thoughts?  This is the second try at this and it's pretty frustrating. (The first was a server that I'd used with a lot of testing so I was hoping for better results with a fresh install.

 

Thanks,

Jerry

Outcomes