AnsweredAssumed Answered

SugarCRM CE will not install on CENTOS system

Question asked by on Mar 5, 2016
Latest reply on Mar 8, 2016 by Alan Beam

I'm trying to get SugarCRM CE installed on a Centos server.  I have gone through adding all the necessary compilers, php plugins, etc and pointing Apache to the right directory.  I have unzipped the latest 6.5 download into that directory and changed all the ownership and permissions on those files.


When I run the install - first problem is that Sugar insists that I'm incapable of typing the password correctly twice to create a new database user.  That's annoying, but I was able to get it working by using the admin user for Sugar (far from ideal, but at least it works).  That allows me to complete the setup screens and start the install process, but that just hangs after database creation.  Checking the php_errors.log I get


PHP Fatal error:  require_once(): Cannot redeclare class currency in /var/www/portfolio/SugarCRM/install/performSetup.php on line 175


I've tried some simple hacks around that line of code, but it seems to me that this installer is broken somewhere.  Can anyone tell me what's off with my system or how to get this install process to run please?