AnsweredAssumed Answered

Config_override.php is reverted back

Question asked by Jonathan Houle on Feb 15, 2016
Latest reply on Feb 17, 2016 by Jonathan Houle

[Edit: Just changed the subject, please go to my reply below for more recent details]

 

Hi,

 

I can't save settings in the admin panel. Like password management or system settings.

But it worked a couple of times occasionnaly when trying, but I can't figure out why.

 

  • I'm running a SugarCRM bitnami VM.
  • Owner of all files is deamon:daemon.
  • Permission is 777 for the test. Upgrade wizard is saying all files are writtable.
  • config.php is set as :     'dir_mode' => 1533,    'file_mode' => 436,    'user' => 'daemon',    'group' => 'daemon'
  • I disabled mod_pagespeed to be sure
  • I can see that config_override date change when I save settings, but nothing is written in file. If I change settings manually in file it's working.
  • Tried rebooting apache
  • To my knowledge, no specific errors in sugarcrm.log or apache error_log. Can't see any errors...
  • Could it be a issue related to the host_name/site_url. My server internal address is 10.x.x.x port 80. External address is mydomain.com:8080. I used the external URL for host_name/site_url. Like if the writting operation in config_override is blocked someway.
  • I saw a post in the community and the guy said that php-fpm was not running php as deamon user on his server. But I'm no linux/php expert.

 

I need some ideas here!

 

Thanks,

 

Jonathan

 

Message was edited by: Jonathan Houle

Outcomes