AnsweredAssumed Answered

new install has bizarre side-effects

Question asked by dave1234 on Jan 11, 2016
Latest reply on Jan 13, 2016 by dave1234

greetings,

 

i've just installed sugar and as i try to get it set up, i'm noticing some very strange behaviour.  this is a brand new install of sugar ce 6.5.22 on a linux system [centos 6.x], running apache and php 5.4.

 

i'm concerned because a number of operations don't seem to succeed, and i get various strange pop-ups saying only 'undefined' [see below for one example].

Untitled-1.jpgsometimes a much larger pop-up is raised, with the title bar saying 'undefined', and the main section of the window showing only '"content:"'.

 

i created a test user with normal user privileges, and was able to log in as this user. the first-login password change went fine, but the user can't access any of the menu tabs. hovering over them does nothing, clicking them does nothing. i logged out and tried logging in again, and login was refused using the new password. i then tried the old, automatically-generated password, and login was also refused.

 

i logged in again as admin, and went to edit the test user's profile. on the test user's edit profile page, there is a tab labeled 'access', and i see here all functions are shown as having 'access' as 'enabled' and 'all' for all of the other columns. when i try to reset the user's password using the 'edit' pull-down, i get one of the 'undefined' pop-ups i mentioned earlier.

 

looking in the log file, i see several warnings. some examples are :

 

[898777][-none-][WARN] Image dashboard.png not found

[901357][1][DEPRECATED] Using row number in fetchByAssoc is not portable and no longer supported. Please fix your code.

[903361][1][WARN] Image icon__32.png not found

[903428][1][DEPRECATED] SugarBean.php: preprocess_fields_on_save() is deprecated

[903428][1][ERROR] Unable to load custom logic file: include/SugarSearchEngine/SugarSearchEngineQueueManager.php

 

don't know if these have anything to do with what's happening. could it be that an incomplete release has been distributed ?  the file i downloaded is called 'SugarCE-6.5.22.zip'.

 

any help appreciated !

 

thanks.

Outcomes