M M

Permission denied in /var/www/sugarcrm/include/utils/autoloader.php:1234

Discussion created by M M on Oct 15, 2015
Latest reply on Oct 27, 2015 by M M
I got error message in log.
It may be a cause that I can't clear cache and build a new dashlet? 
(Create custom dashlets not showing ?)

[FATAL] Exception in Controller: exception 'UnexpectedValueException' with message 'DirectoryIterator::__construct(./custom/modules/Home/Ext/clients/): failed to open dir: Permission denied' in /var/www/sugarcrm/include/utils/autoloader.php:1234Stack trace:#0 /var/www/sugarcrm/include/utils/autoloader.php(1234): DirectoryIterator->__construct('./custom/module...')
#1 /var/www/sugarcrm/include/utils/autoloader.php(1241): SugarAutoLoader::scanDir('custom/modules/...')
#2 /var/www/sugarcrm/include/utils/autoloader.php(1241): SugarAutoLoader::scanDir('custom/modules/...')
#3 /var/www/sugarcrm/include/utils/autoloader.php(1241): SugarAutoLoader::scanDir('custom/modules/...')
#4 /var/www/sugarcrm/include/utils/autoloader.php(1241): SugarAutoLoader::scanDir('custom/modules/')
#5 /var/www/sugarcrm/include/utils/autoloader.php(1241): SugarAutoLoader::scanDir('custom/')
#6 /var/www/sugarcrm/include/utils/autoloader.php(1063): SugarAutoLoader::scanDir('')
#7 /var/www/sugarcrm/modules/Administration/QuickRepairAndRebuild.php(304): SugarAutoLoader::buildCache()
#8 /var/www/sugarcrm/modules/Administration/QuickRepairAndRebuild.php(140): RepairAndClear->rebuildFileMap()
#9 /var/www/sugarcrm/modules/Administration/views/view.repair.php(35): RepairAndClear->repairAndClearAll(Array, Array, false, true, '')
#10 /var/www/sugarcrm/include/MVC/View/SugarView.php(137): ViewRepair->display()
#11 /var/www/sugarcrm/include/MVC/Controller/SugarController.php(308): SugarView->process()
#12 /var/www/sugarcrm/include/MVC/Controller/SugarController.php(256): SugarController->processView()
#13 /var/www/sugarcrm/include/MVC/SugarApplication.php(116): SugarController->execute()
#14 /var/www/sugarcrm/index.php(27): SugarApplication->execute()
#15 {main}

SugarCRM Professional, Version 7.5.2.0 

How to fix it ? 

Thank you,
M

Outcomes