AnsweredAssumed Answered

I'm trying to create Installable Package That Copies Files. but once i try to upload the package, it gives an error.

Question asked by ymadu on Aug 31, 2015
Latest reply on Aug 31, 2015 by Matt Marum
MERGED
This conversation has been merged. Please reference the main conversation:
I'm trying to create Installable Package That Copies Files. but once i try to upload the package, it gives the bellow error.

The uploaded file is not compatible with this version of Sugar: 6.5.22

this is the code

<?php
    $manifest =array(
        'acceptable_sugar_flavors' => array('CE','PRO','CORP','ENT','ULT'),
        'acceptable_sugar_versions' => array(
            'exact_matches' => array(),
            'regex_matches' => array('6\\.[0-9]\\.[0-9]$'),
        ),
        'author' => 'SugarCRM',
        'description' => 'Installs a sample logic hook',
        'icon' => '',
        'is_uninstallable' => true,
        'name' => 'Example Logic Hook Installer',
        'published_date' => '2012-07-06 2012 20:45:04',
        'type' => 'module',
        'version' => '1341607504',
    );
    
    $installdefs =array(
        'id' => 'package_1341607504',
        'copy' => array(
            0 => array(
                'from' => '<basepath>/Files/custom/modules/Accounts/accounts_save.php',
                'to' => 'custom/modules/Accounts/accounts_save.php',
            ),
        ),
        'logic_hooks' => array(
            array(
                'module' => 'Accounts',
                'hook' => 'before_save',
                'order' => 99,
                'description' => 'Example Logic Hook - Updates account name',
                'file' => 'custom/modules/Accounts/accounts_save.php',
                'class' => 'Accounts_Save',
                'function' => 'updateAccountName',
            ),
        ),
    );

?>

Outcomes