AnsweredAssumed Answered

Error at a new subpanel

Question asked by Dr.To Dr.To on Jul 24, 2015
Latest reply on Jul 29, 2015 by Maksim Nesterenko
Hey Guys,
I create in /custom/modules/Accounts a link for a subpanel form my own module..
When i look at the sugarcrm.log i have this Error  failed to find link for "subpanelname".


In the subpanel.php in den module Accounts i have this Code:
array(
          'layout' => 'subpanel',
          'label' => 'LBL_ICC_AUFTRAEGE',
          'context' => array(
              'link' => 'icc_auftraege',
          ),
      ),


In der vardefs.php form the Account module i have this Code:
'icc_auftraege' => array(
            'name' => 'icc_auftraege',
            'type' => 'link',
            'relationship' => 'account_icc_auftraege',
            'module' => 'ICC_Auftraege',
            'bean_name' => 'ICC_Auftraege',
            'source' => 'non-db',
            'vname' => 'LBL_ICC_AUFTRAEGE',
        ),


And this for the relationship:
'account_icc_auftraege' => array(
            'lhs_module' => 'Accounts',
            'lhs_table' => 'accounts',
            'lhs_key' => 'id',
            'rhs_module' => 'ICC_Auftraege',
            'rhs_table' => 'icc_auftraege',
            'rhs_key' => 'id',
            'relationship_type' => 'one-to-many',
            'relationship_role_column' => 'parent_type',
            'relationship_role_column_value' => 'Accounts'
        ),



Does anyone have any idea how I can fix it?


Greetings
Dr.To

Outcomes