AnsweredAssumed Answered

cleaning up the logs in 7.5.x

Question asked by Francesca Shiekh on May 28, 2015
Latest reply on Oct 26, 2016 by Roman Nique
It has long been my goal to have clean logs, that is, logging set at "Error" and NO entries in the log. Utopia?


As of 7.5.1 Pro my logs are full of entries like this:
Thu May 28 09:11:33 2015 [21573][28297735-afdc-8454-75c8-4e43d1beeac0][ERROR] Unable to get proper side for link modified_user_linkThu May 28 09:11:33 2015 [21573][28297735-afdc-8454-75c8-4e43d1beeac0][ERROR] Unable to get proper side for link created_by_link
Thu May 28 09:11:33 2015 [21573][28297735-afdc-8454-75c8-4e43d1beeac0][ERROR] Unable to get proper side for link assigned_user_link
And this:
Thu May 28 09:13:52 2015 [22096][b455bc65-f6a8-cdd9-e4b3-4fc4c67323f3][ERROR] An exception happened: ( 412: metadata_out_of_date)Your metadata or user hash did not match the server. Please resync your metadata.  
And this:
Thu May 28 09:10:26 2015 [22096][cc32d3e5-e22d-7400-0a69-52a747830356][ERROR] Unable to get proper side for link project_name_link  Thu May 28 09:10:26 2015 [22096][cc32d3e5-e22d-7400-0a69-52a747830356][ERROR] Unable to get proper side for link default_primary_team  Thu May 28 09:10:26 2015 [22096][cc32d3e5-e22d-7400-0a69-52a747830356][ERROR] Unable to get proper side for link assigned_user_link  Thu May 28 09:10:26 2015 [22096][cc32d3e5-e22d-7400-0a69-52a747830356][ERROR] Unable to get proper side for link contracts  Thu May 28 09:10:26 2015 [22096][cc32d3e5-e22d-7400-0a69-52a747830356][ERROR] Unable to get proper side for link leads
And
Thu May 28 09:17:02 2015 [22687][-none-][ERROR] An exception happened: ( 401 Unauthorized: invalid_grant)The access token provided has expired.
And:
Thu May 28 09:18:34 2015 [23137][1][ERROR] SugarBean.load_relationships, Null relationship name passed.  Thu May 28 09:18:34 2015 [23137][1][FATAL] could not load RHS  in Activity
The errors with user_id = 1 should be from schedulers, but I can't figure out which jobs cause this. Is there a way to track the job id from the log entry? What is the number before the user_id?

The 'proper side for link" seems to be relationship issues, but rebuilding relationships is not fixing the problems, and there is no evidence that users are even noticing.

Any thoughts on how to debug/fix these issues and thus clean up the log?
thanks,
FrancescaS

Outcomes