AnsweredAssumed Answered

Undefined labels in Studio Layout Editor - The Old Permissions Problem?

Question asked by Jeff C on May 6, 2015
Latest reply on May 16, 2016 by Alexander Cope-Norris
In the Studio Layout Editor, on top of the field are usually an element labeled 'new row' and 'filler'.  However, it's labeling though items as 'undefined'.  I know this is using a permissions problem having to do with the language files I think.  But I've tried everything to remedy and still no fix.  This is what I've done:

chown -R : 
(Replacing  and  with user and group name for that particular website)

chmod -R 755 
(note that a previous post suggested using 775 for this - this will cause 500 error with apache error that the PHP file is group writable - guess this is default security of Cpanel?)

chmod -R 775 cache custom modules themes data upload config_override.php
(executed from within  of course)

rm -fr cache/*
(clear out all cache files)

Edit default permissions in config.php to this:

   'default_permissions' =>   array (
     'dir_mode' => 02775,
     'file_mode' => 0775,
     'user' => '',
     'group' => '',
   ),

Run Quick Repair.

After all that - no change.

Outcomes