AnsweredAssumed Answered

Lotus Notes Database Corruption

Question asked by kedarhandal kedarhandal on Apr 24, 2015
Latest reply on Apr 25, 2015 by hartviglarsson hartviglarsson
The database size limit was initially 1 GB. Then when the size exceeded the limit , the limit was upgraded to 4 GB. Thereafter, there was a design refresh carried out to undertake some design enhancements. After this, the database was working fine, till 2days back. The size currently is - 2.5 GB. The series of errors in appropriate sequence are listed below:

1. First an error was observed on accessing/adding the database icon - Server Error: This database cannot be read due to an invalid on disk structure- End User client

2. Then, an attempt to force a COMPACT of the database but with no success. Also tried an UPDALL and a FIXUP. None of the Notes utilities can touch the database - the error "Object is corrupt" is returned.- Admin Client

3. The database now gives the  following message when we try to access it.-This Database cannot be opened because a consistency check of it is needed.- End User client

4. Re-tried a COMPACT and FIXUP. Both failed with the error message:- Admin Client

** Live console connected to server xxx**
> xx/xx/2001 10:36:31     Performing consistency check on
xxx.nsf...

> 29/03/2001 10:36:38     Unable to fixup database xxx.nsf:
File truncated - file may have been damaged


Now, the question is :

1. Is this a size problem ?
2. When do these kind of errors occur & why?
3. What are the possible solution to retrieve the database ?
4. Is it likely to repeat and in what scenarios ?

Outcomes