AnsweredAssumed Answered

System Check Errors (PHP version, MySQL database support)

Question asked by Numan Sheikh on Mar 11, 2015
Latest reply on Mar 12, 2015 by Numan Sheikh
Hi All,

I'm installing 7.5.0.1 Sugarcrm on my own physical linux server and have installed apache 2.4, mysql 5.5 and php 5.4.38.

For the php issue (Your version of PHP is not supported by Sugar. You will need to install a version that is compatible with the Sugar application. Please consult the Compatibility Matrix in the Release Notes for supported PHP Versions. Your version is 5.5.9-1ubuntu4.6 ))

The server was running 5.5.9 and I installed phpbrew and downgraded to 5.4.38.  Below is the php version running on the box:
root@koa:/# which php/root/.phpbrew/php/php-5.4.38/bin/php
root@koa:/# php -v
PHP 5.4.38 (cli) (built: Mar  5 2015 08:37:45)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
root@koa:/#

I'm not sure why system check is failing for this...

For the mysql error it says 

              Obtain the proper driver files corresponding to your database, server architecture, and PHP version.  From this website: 
                http://us.php.net/manual/en/book.mysqli.php
               
     
  1. Place the driver files into PHP's extension_dir folder.
  2.  
  3. Add an extension line into your php.ini file loading the driver file (e.g. extension=php_mysqli.dll).
  4.  
  5. Restart your web server.
  6.  
The directions are not that good on the php.net and I don't know what driver files to put into the extensions folder.

Any help would be great!!

Outcomes