AnsweredAssumed Answered

Overridden API stops working after upgrade from 7.2 to 7.5

Question asked by Steve Cox on Jan 15, 2015
Hi,

I had a version 7.2 installation working fine. I had overridden the Account REST API - to modify the 'retrieveRecord' call, to set some fields via custom functions.

After upgrading to 7.5, the system, has stopped using this and has gone back to using the vanilla ModuleApi call for accounts.

I've tried to debug via breakpoints, I can see the custom file's registerApiRest being called for the new API. But when it comes to calling against it, the old one is still used.

Any thoughts on how to approach this?

Outcomes