Fredy Sanchez

6.5.18 to 6.5.20 update messes up GUI components

Discussion created by Fredy Sanchez on Feb 10, 2015
Latest reply on Feb 11, 2015 by Fredy Sanchez
Hi all,

After installing the update in our dev box thru the silent updater (this worked just fine), running a "Quick Repair and Rebuild" and "Rebuild Relationships," and rebooting the server, many of the Sugar UI components remain broken (see links). I thought this was a permissions problem, but I've changed the permissions in every other way to no avail; my current permissions script is linked to. I also replaced the sugar filesystem and database using the ones from our production instance, which is working just fine; no dice. However, the UI components will work fine if you go to them directly, by say going to https://sugar-dev.modernizingmedicine.com/sugar/index.php?module=Administration&action=index. There is nothing noticeable on the logs either (sugarcrm.log, /var/log/httpd/error_log) ; but I can provide the diagnostics info from Sugar if needed. Any ideas? Thank you very much.

Amazon Linux AMI 2014.09
php.x86_64     5.3.29-1.7.amzn1  
httpd.x86_64   2.2.29-1.4.amzn1
mysql.noarch  5.5-1.6.amzn1

Screenshots and permissions script: https://drive.google.com/folderview?id=0B2O4b3UzmGjhflhHejdNM3VHcENPbldRbzJVTWpqTlFXOW9ldUJyVGZ0MDkwSUZ4dE80ME0&usp=sharing


I should also mention that I already spent some time in Google. Some links I already tried:
http://support.sugarcrm.com/02_Documentation/01_Sugar_Editions/02_Sugar_Enterprise/Sugar_Enterprise_...
SugarCRM - Bizarre behaviour!
http://support.sugarcrm.com/04_Knowledge_Base/02Administration/100Troubleshooting/Troubleshooting_Is...
http://forums.sugarcrm.com/f115/upgrade-sugarcrm-ce-6-4-5-6-6-5-layout-messed-up-82829/

Outcomes