AnsweredAssumed Answered

Elastic Search PHP Library not found on install of 7.5.0.1

Question asked by chadhutchins on Dec 30, 2014
Latest reply on Mar 5, 2015 by KarlMetum KarlMetum
I'm trying to install a clean 7.5.0.1 build from the development repository. I noticed the Elastica PHP library which used to live in vendor/Elastica does not exist. It looks like it's being pulled in via composer now (which is nice). After running "composer install" in the root Sugar directory it pulls down the library correctly from its source in 
                vendor/ruflin/elastica/lib/Elastica.

During the installation process I keep receiving an error: Fatal error: Class 'Elastica\Client' not found in include/SugarSearchEngine/Elastic/SugarSearchEngineElastic.php on line 85. This happens after clicking "Next" on the step where you have to fill out your database credentials and elasticsearch details.

Do I need to do anything special to make sure this and the other composer libraries are autoloaded with everything else?

Thanks!

Outcomes