AnsweredAssumed Answered

Error in popup window  - Content":"

Question asked by Kerry Kerry on Aug 24, 2014
Latest reply on Aug 30, 2014 by Kerry Kerry
I have seen numerous posts on this issue and I've tried solutions as best as I can.
I am running SugarCRM Community v6.5.16 on a shared CentOS server at Hostgator.

I am not a programmer. Just a user. So I'm hoping somebody can point me in the right direction. Maybe the solution is out there already but I'm not able to understand it.

When I install the system seem to be fine for a period of time. Light usage over a few days or couple of weeks has no problems. Then suddenly, out of the blue the problems start. Sometimes there are pop up windows all over the place that just say undefined. Sometimes it's a large pop up window with the error -  Content":"

Various articles have had me change permissions on the cache directory and sub directories to 777. By default they are 755. However even I know this is a security risk. When I contacted HostGator about it they freaked out and said they don't allow 777 but they, and most providers use suPHP servers with allow scripts to read write and execute without the security issues.

Another article told me to change the config.php starting at line 185:

 array (
    'dir_mode' => 1528,
    'file_mode' => 432,
    'user' => '',
    'group' => '',
  ),

I was told to change the user and group to whatever my provider told me. When I did that all I got were error messages about chowner not allowed.

Other articles send me in directions I don't understand at all.

So here I am lost. Our workaround for now has been to backup the data once the errors start, do a fresh install and restore the data. This works for a few days or weeks until the errors start returning.

Is there any help for this? --- for laymen? I've seen posts about this problem going back to 2010 in the old forum. Has it ever been solved?

Any help appreciated

Kerry

Outcomes