AnsweredAssumed Answered

"Test for .htaccess rewrites failed. This usually means you do not have AllowOverride set up for Sugar directory." error during installation

Question asked by Marco Pierobon on Jul 30, 2014
Latest reply on May 16, 2018 by Baishakhi Karmakar
Hi,

I am setting up a new environment on a fresh Ubuntu install.
I copied the installation files for Sugar 7.2 Enterprise and I started the installation process.

During the check I get this message

Test for .htaccess rewrites failed. This usually means you do not have AllowOverride set up for Sugar directory.

I ensured that the mod_rewrite was active, I added the lines 


<Directory /var/www/>

        AllowOverride All

</Directory>

<Directory /var/www/sugar/>

        AllowOverride All

</Directory>



to the /etc/apache2/apache2.conf



and the 

<Directory /var/www/>

                Options Indexes FollowSymLinks MultiViews

                AllowOverride All

                Order allow,deny

                allow from all

</Directory>

<Directory /var/www/sugar/>

                Options Indexes FollowSymLinks MultiViews

                AllowOverride All

                Order allow,deny

                allow from all

</Directory>



To /etc/apache2/sites-available/default



But I still get the error message. I have been through several installations, but I've never seen anything like this before.

What is there left to check?

Outcomes