AnsweredAssumed Answered

FYI: Contrary to documentation PHP 5.3.6 or higher is needed for v7.2

Question asked by Francesca Shiekh on Jul 7, 2014
Latest reply on Jul 9, 2014 by philipzaengle philipzaengle
FYI

I noticed that 
The supported platforms documentation at:

http://support.sugarcrm.com/05_Resources/03_Supported_Platforms/
Sugar 7.2.x Supported Platforms
states:  PHP 5.3.25

But in UpgradeModule.php for the 7.2.0 installer they use the DEBUG_BACKTRACE_IGNORE_ARGS which is only available starting in PHP 5.3.6 and higher ( http://www.php.net/manual/en/function.debug-backtrace.php )

and in the silent upgrade from 7.2.0 to 7.2.1 they use SplFileInfo::getExtension() in /var/www/html/upgrades7/UpgradeDriver.php on line 1162 which is only available in PHP 5.3.6 and higher ( http://www.php.net/manual/en/splfileinfo.getextension.php )

I have reported this to Sugar Support.
FrancescaS

Outcomes