AnsweredAssumed Answered

Upgrade error from upgrades/temp/scripts folder

Question asked by gperez gperez on Jul 2, 2014
Latest reply on Jul 3, 2014 by gperez gperez
Hi
I'm in troubles, trying to upgrade Sugar CE 6.2 to 6.3.3 
I did this just fine in my localhost by I'm having several issue in prod. 
Database is the same, and code should be very similar. 
By other hand, i'm running linux mint while production is using Freebsd. But that shouldn't be a problem.

Tried both GUI Upgrade Wizard and the silent upgrade. And the most annoying issue is that the cache target folder is wrong.
See. Instead of creating this:
cache/upload/upgrades/temp/scripts/*
Target folder is 
cache/upload/upgrades/temp/scripts/scripts/*

So, there's an extra "scripts" folder. After unziping the upgrade file, it continues looking for the scripts in the right folder (upgrade_utils.php) but it just can't find it.

I tried copying the files from /scripts/scripts/ to /scripts/ but that doesn't solve the problem. Several new issues appear. Why? I'm up to cry after hours of anxiety (no, I'm not, but I'm worried).

I searched for this issue and there's nothing similar in the forums. 

Outcomes