AnsweredAssumed Answered

Error with Report menu not rendering (Enterprise 6.5.x)

Question asked by Scott Romito on May 14, 2014
When clicking the Reports menu item, the normal screen doesn't render at all, and we get some raw data, which starts with:
ACLAllowedModules = 
["Leads","Cases","Bugs","Prospects","Project","ProjectTask","Campaigns","CampaignLog","Releases","Contacts","Accounts","Opportunities","Notes","Calls","Emails","Meetings","Tasks","Users","Currencies","Trackers","TrackerSessions","TrackerPerfs","TrackerQueries","Documents","DocumentRevisions","EmailAddresses","Teams","Quotes","Products","ProductTypes","ProductCategories","Forecasts","Contracts","KBDocuments","la_LoginAudit","sync_Email_Hist","Iframeapp","invoi_Invoices"];
and after lots of other code, ends with

field_defs_DocumentRevisions[ "doc_type"] = 
{"name":"doc_type","vname":"Source","type":"enum","function":"getDocumentsExternalApiDropDown","len":"100"};var option_arr_DocumentRevisions = new Array();

We use the Sugar plug-in for Excel, and when trying to pull a report into Excel, we get a similar error, though it begins with:

Client found response content type of 'text/html; charset=utf-8', but expected 'text/xml'.

followed by the same text as the Reports menu spits back ('ACLAllowedModules....').

The Excel plug-in *is* able to manually run queries against Sugar, which is a blessing, but not a long-term solution.

I noticed a post on StackExchange that describes exactly the issue, but no concrete solution either: http://stackoverflow.com/questions/10942555/sugarcrm-reports-module-not-formatted

Any help appreciated. I'm fine with amending Sugar's code, but have no idea what to look for.

Thanks!




Outcomes