AnsweredAssumed Answered

Custom module is not showing the subpanel from another module

Question asked by red one on Apr 18, 2014
Latest reply on Jun 22, 2014 by sonesay inthavong
i'm new with sugar crm i'm using Sugar CE 6.5.16 with MySQL
and IIS7 windows.
i created two modules, deploy them, add custom fields and layouts.
evrything works fine.In Order to get a detailed view for the primary
module with a subpanel listing the items from the second module being
related to it..i made a one-to-many relationship between these two
modules. the problem is when clicking on the primary module elemants
nothing shows up (there is no detail view or anything else) the
secondary module did show a new field to relate items to it and the
details view is fine.
evrything was done via studio and module builder. no file editing was
made.
i'm thinking the issue is in this file:
\custom\modules\Primary_module\Ext\layoutdefs\layoutdefs.exe.php :

<?php 
//WARNING: The contents of this file are auto-generated
// created: 2014-04-17 15:19:10
$layout_defs["plt01_Chassis"]["subpanel_setup"]['plt01_chassis_plt01_cartes_1'] =array   (
'order' => 100,
'module' => 'plt01_Cartes',
'subpanel_name' => 'default',
'sort_order' => 'asc',
'sort_by' => 'id',
'title_key' => 'LBL_PLT01_CHASSIS_PLT01_CARTES_1_FROM_PLT01_CARTES_TITLE',
'get_subpanel_data' => 'plt01_chassis_plt01_cartes_1',
'top_buttons' =>
array (
0 =>
array (
   'widget_class' => 'SubPanelTopButtonQuickCreate',
),
1 =>
array (
   'widget_class' => 'SubPanelTopSelectButton',
   'mode' => 'MultiSelect',
),
),
);
//auto-generated file DO NOT EDIT
$layout_defs['plt01_Chassis']['subpanel_setup']['plt01_chassis_plt01_cartes_1']['override_subpanel_name'] = 'plt01_Chassis_subpanel_plt01_chassis_plt01_cartes_1';
?>


  because when i delete the content the detailed view appear but no subpanels...any help please?



Outcomes