AnsweredAssumed Answered

"Unable to connect to Full Text Search server, please verify your settings" during install wizard

Question asked by rsanper rsanper on Mar 13, 2014
Latest reply on Mar 14, 2014 by rsanper rsanper

I hope you can help me...

I'm getting this error in sugarcrm's install.log:

2014-03-14 00:25:09...FTS connection results: array (
'valid' => false,
'status' => 'Couldnt connect to host, ElasticSearch down?',

when trying to connect sugarcrm pro 7.1.6 to elasticsearch 0.90.6 (as recommended) while configuring installation wizard to use localhost:9200 or IP:9200

and I have checked that elasticsearch is currently up and running:

# curl -X GET 'http://localhost:9200'
"ok" : true,
"status" : 200,
"name" : "crm",
"version" : {
"number" : "0.90.6",
"build_hash" : "e2a24efdde0cb7cc1b2071ffbbd1fd874a6d8d6b",
"build_timestamp" : "2013-11-04T13:55:15Z",
"build_snapshot" : false,
"lucene_version" : "4.5.1"
"tagline" : "You Know, for Search"

but I if take a look at sugarcrm's sugarcrm.log I can see this exception

Fri Mar 14 01:25:09 2014 [2005][-none-][FATAL] Unable to get server status: Elastica_Exception_Client

I'm using CentOS 6.5 with java version java version "1.7.0_51" (client), apache 2.2.15, php 5.3.3 and MySQL 5.5.36.

Also tried sugarcrm pro 7.1.0 and 6.5.16 with the same results.
Also tried ElasticSearch 0.90.10, 0.90.12, 1.0.1 with the same results.

Tried to capture traffic (tcpdump/wireshark) between sugarcrm and elasticsearch to test if sugarcrm is trying to connect (at least SYN TCP...) to elasticsearch but I couldn't see any traffic. On the other hand I can see it if I send previous curl. So I guess sugarcrm is not trying to connect to ElasticSearch, "Elastica_Exception_Client" fails before, not allowing it.

Is there any problem in SugarCRM's ElasticSearch client?

I'm running out of ideas...