AnsweredAssumed Answered

Sugar 7.1 mysql connection issues

Question asked by jschall on Feb 21, 2014
Latest reply on Jul 8, 2016 by Mark Willert
What the flip! So I am honestly at my wits end here because I cannot figure out this issue for the life of me. I want to use CentOS 6.5 for installing 7.1.5 I can install just fine using ubuntu. But for some reason on CentOS I cannot get past the connection part to mysql. It tells me wrong user or password or address and cannot get a connection to the Elastic server. So here is my setup. I have 3 servers. 1 for elasticsearch 1 for the mysql and 1 for sugarcrm. If I log into the sugarcrm ssh console I can connect into the database just fine so I know that works. Same with if I use curl http:address:9200 for elastics I see that I can connect into elasticsearch just fine. Now for testing purposes I went ahead and dropped the firewalls on all the server just in case. Still nothing. So I look at the logs. in the sugar dir in install.log and get the following:

               

2014-02-21 12:54:18...FTS connection results: array (

 

  'valid' => false,

 

  'status' => 'Couldnt connect to host, ElasticSearch down?',

 

)

 

2014-02-21 12:54:18...ERROR:: Unable to connect to FTS.Elastic

 

2014-02-21 12:54:18...FATAL:: errors have been detected!  User will not be allowed to continue.  Errors are as follow:

 

2014-02-21 12:54:18..... The provided database host, username, and/or password is invalid, and a connection to the database could not be established.  Please enter a valid host, username and password

 

2014-02-21 12:54:18..... Unable to check database version.

 

2014-02-21 12:54:18..... Unable to connect to Full Text Search server, please verify your settings.

 

2014-02-21 12:54:18...End DB Check Process *************


ok not anything good here. Its just telling me the same thing that the installer said. So I go and look in the httpd/apache error logs. Here is what this is saying: 


               

PHP Warning:  mysqli_query() expects parameter 1 to be mysqli, boolean given in /var/www/sugarcrm/include/database/MysqliManager.php on line 143, referer: http://website.com/install.php


Looked at the code. Looks like everything is using the mysqli command which uses the php module mysqli.so which I double checked is installed by running php -m. I dunno am I missing something here? Maybe I am missing some other module. Here is my list of installed modules:

bcmath

bz2

calendar

Core

ctype

curl

date

dom

ereg

exif

fileinfo

filter

ftp

gd

gettext

gmp

hash

iconv

imap

json

ldap

libxml

mbstring

mysql

mysqli

odbc

openssl

pcntl

pcre

PDO

pdo_mysql

PDO_ODBC

pdo_sqlite

Phar

readline

Reflection

session

shmop

SimpleXML

soap

sockets

SPL

sqlite3

standard

tokenizer

wddx

xml

xmlreader

xmlrpc

xmlwriter

xsl

zip

                                                                                                                       

zlib


I mean honestly it shouldn't be this complicated ha. Any help would be appreciated!

Outcomes