Installation stuck on PHP version validation

Idea created by Lpu8er Lpu8er on Oct 29, 2015
    • Lpu8er Lpu8er
    Just getting the installation stack from official partner portal for Sugar CRM 7.5 PRO.

    I know that SugarCRM does only have "official support" for obsolescent versions (ElasticSearch 0.9, PHP < 5.4 and so on) but why the installer still stuck on PHP version stuck, without any "I'll take my chances" or something like that, in order to by-pass such checks ?

    By testing, I proved that SugarCRM DOES run on PHP >= 5.4. Just have to redeclare the deprecated functions session* (and from a loooong time, they're deprecated, see : ).

    I'm not installing it on a On-Demand, but really on a local environment in order to deliver packages. So I don't get why I'm stuck on such a false prerequesite.

    So, here is a simple idea : allow users to by-pass version validation, if installed version is more recent (and decent) than current version. You may add an additional warning for users, if you want to keep the things simple; that's your concern.

    But actually, that means : "SugarCRM is NOT compatible with non-obsolescent versions of PHP and so on" instead of "SugarCRM supports PHP 5.3.x".